icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.wo-business.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

乐彩客彩票 www.2289.org-今天的彩民乐图文版| www.03rf.com-彩票导师带回血| www.xf49.com-四九彩票网-| www.763629.com-陕西体彩中心官网| www.906751.com-福彩地方彩种开奖| www.ya52.com-ll彩票注册-| www.7007.cn-体彩猜球规则| www.i44.bid-银川福彩大奖| www.36888.cc-天齐彩票网-| www.227539.com-中国体彩大乐透规则| www.335984.com-体育彩票怎么代理| www.424013.com-三国杀张星彩| www.524924.com-易彩乐快三平台| www.607779.com-韩国彩票中奖号| www.687790.com-彩票代理日结反水| www.776338.com-欢乐彩骗局-| www.859806.com-福彩双色球几点封盘| www.931443.com-中彩票咒语-| 乐盈彩票www.89980.cc| www.fx97.com-白岩松彩票揭秘| www.959273.com-捡彩票-| www.112152.com-中三亿彩票-| www.198396.com-快三坑了多少人| www.813718.com-福彩代理是什么意思| www.968504.com-福彩双色球作弊| www.206382.com-黑客黑入彩票平台| www.4342.xyz-黑彩刘雪龙-| www.540043.com-快三表演视频| www.221735.com-玩金利彩票被骗| www.358976.com-怎么选七星彩号码| www.400263.com-网上玩8彩犯法吗| www.678808.com-开福彩店哪些赚钱| www.62533.cc-河南休彩开奖结果| www.678.cc-彩民彩票世界杯玩法| www.71328.com-幸运彩下载app| www.878962.com-福育彩票开奖结果| www.952814.com-福彩开奖结结果| CP701www.627792.com| www.936151.com-福彩时时彩开奖号| 818合彩www.www.9889hc.com| www.136273.com-桂林体彩中心在哪里| www.220259.com-豪门彩票app| www.531829.com-学玩彩票技术| www.301487.cc-福利彩票三地| www.230204.com-大发彩app下载| www.600197.com-不买彩票还想着中奖| www.001035.com-体彩61开奖-| www.134392.com-南通市体彩中心电话| www.222063.com-王牌彩票app| www.4594.biz-彩票超过一万| www.16768.cc-大连福彩-| www.525110.com-十大网彩黑桃k| www.543799.com-彩票遇到连挂怎么办| www.01480.com-购买足彩的网站| www.m79.xyz-彩票查询快三内蒙| www.378352.com-100万彩票app| www.713270.com-52亿彩票-| www.807237.com-竞猜足彩玩法| www.912315.com-体彩中国红中奖率| www.982150.com-双色球新浪彩票| www.443099.com-网易红彩怎么破解| www.632859.com-福彩2d地区-| www.758808.com-有阿里彩票吗| www.838052.com-五百万彩票竞彩网| www.947519.com-彩票假不假-| 118彩票www.62118f.com| www.oe.com-网络快三可以玩吗| www.4625.cm-体彩篮球投注| www.76393.cc-彩票带单老师可靠么| www.53765.cc-竞彩店怎么申请退款| www.188726.com-福建快三2同号遗漏| www.53526.cc-丰大彩票app| www.017365.com-cp彩票平台-| www.110159.com-爱彩乐彩票数据提醒| www.211184.com-大发快三能不能赢钱| 百姓彩票www.bxcp3.com| www.035012.com-神彩趋势软件下载| www.546365.com-广州福利彩票转让| www.52634.com-看彩票开奖结果| www.036911.com-中国第一彩-| www.170120.com-河北省快三结果| www.081376.com-电台足彩推荐骗局| www.175912.com-大发快三网页计划| www.916479.com-海南私彩举报电话| www.972643.com-彩铅意境画-| www.yd.com-河北福彩3d预测| www.pi75.com-辽宁快三在线开奖| www.425941.com-竞彩亏钱-| www.435656.com-福彩公众号是多少| www.283788.com-七星彩中奖规则图片| www.517714.com-福利彩结果-| www.587318.com-鸿福彩票诈骗| www.666340.com-鑫乐彩彩票-| www.745895.com-新时代彩票平台| www.894797.com-彩票中奖地区查询器| www.986449.com-竞彩篮球开奖结果| www.w05.cc-彩票宣传语录| www.653.net-腾讯分分彩经验贴| www.431321.com-竞彩足球魔方官网| www.074.date-上诲快三开奖| www.8285.bid-万博彩票app| www.4953.cm-盛源彩票网站是多少| www.820746.com-金乡福利彩票机构| www.xa24.com-5分彩怎么玩法| www.2150.tv-国家的彩票有多少种| www.575899.com-牛彩手机登陆| www.sd21.com-正规彩票-| www.418255.com-鼎盛买彩票正规吗| www.8495.cn-福彩售票几点结束| www.19911.com-福彩十二生肖下载| www.255549.com-七星彩中奖规则图表| www.093112.com-彩钢工地围挡报价| www.tj04.com-彩票166开奖结果| www.8998.online下载彩票软件网| www.191981.com-河南快三走势一定牛| www.877575.com-京东彩票网-| www.106209.com-多赢彩票网址| www.381731.com-泰安福彩中奖新闻| www.37174.com-皇家彩地址-| www.79719.com-体彩88-| www.029826.com-10068彩票官网| www.270332.com-888彩票网安卓版| www.341762.cc-一分钟快三交流| www.405629.com-七星彩中奖500万| www.019656.com-o1彩票-| www.55853.cc-新三国打斗精彩| www.203299.com-体彩排列5开奖号码| www.678791.com-竞彩怎么玩-| www.766878.com-糖果彩邀请码| www.869023.com-7星彩投注-| www.927138.com-红旗彩票5566| www.088952.com-天津市时时彩官网| www.579762.com-福利彩试机号今天| www.27hu.com-新加坡乐彩开奖记录| www.3942.cn-天下彩票308| www.8988.tv-新时代彩票网址| www.169021.com-快三彩票实战技巧| www.271813.com-今晚好彩1开什么号| www.29ox.com-迪丽热巴彩铅画教程| www.0797.in-彩票都那几天开奖| www.07259.com-彩色混凝土着色地坪| www.753710.com-双色球预测彩经网| www.414758.com-2019体彩行情| www.514146.com-网彩靠谱吗-| www.67al.com-足球竞彩倾家荡产| www.lm77.com-中彩网网站地址| www.s51.cn-西宁福利彩票中奖| www.549550.com-078彩票一经销商| www.524646.com-大乐透幸运彩乐乐| www.580315.com-世界杯彩票蛋糕| www.650577.com-彩票神算王关注| www.698889.com-初学者简单的彩铅画| www.wm40.com-快三预测app| www.tq64.com-体育彩票申请书范例| www.59tm.com-体彩店还能兼营什么| www.yl21.com-彩票网上买投注站网| www.41zi.com-491彩票cc-| www.1528.xyz-彩宝下载网址多少| www.7239.biz-小鸡彩虹儿歌目录| www.610012.com-19038期7星彩| www.8pi.com-南京市彩票店转让| www.716557.com-儿童星空彩铅简笔画| www.200079.cc-所有彩票开奖结果| www.981749.com-大庄家彩票app|